sensors not displaying

Sensors and DIY

We have placed already 6 measuring points, but only the first one is showing up in the website. What's wrong?

6 comments

Hi Robert. It can sometimes take up to a week for all sensors and data to appear on the website. If it has already been more than a week, please complete this form so we can investigate the problem - http://tinyurl.com/y28vwe8z Many thanks

Reply — Last edited

Hi Sarah, now all data is gone, just showing: Cannot read property 'serialNumber' of undefined with some programming lines...

Hi; Robert send me an email with the complete error message he gets (see his post on the 8th of April) when he goes to data on the growobservatory website. I thought it may be useful to resolve the problem. Can you help?

Here is the error message:

Cannot read property 'serialNumber' of undefined

TypeError: Cannot read property 'serialNumber' of undefined

at /home/forge/hub.growobservatory.org/src/services/sensors.js:111:46

at Array.forEach ()

at _callee4$ (/home/forge/hub.growobservatory.org/src/services/sensors.js:109:11)

at tryCatch (/usr/local/lib/node_modules/babel-cli/node_modules/babel-polyfill/node_modules/regenerator-runtime/runtime.js:65:40)

at Generator.invoke [as _invoke] (/usr/local/lib/node_modules/babel-cli/node_modules/babel-polyfill/node_modules/regenerator-runtime/runtime.js:303:22)

at Generator.prototype.(anonymous function) [as next] (/usr/local/lib/node_modules/babel-cli/node_modules/babel-polyfill/node_modules/regenerator-runtime/runtime.js:117:21)

at step (/home/forge/hub.growobservatory.org/src/services/sensors.js:26:191)

at /home/forge/hub.growobservatory.org/src/services/sensors.js:26:361

at process._tickCallback (internal/process/next_tick.js:68:7)

Thank you Tania. We'll look into this.

Hi Sarah, the map shows up now. Thanks for the support.