Error message upon download of PArrot app on Android 5.11: 'Device not compatible with this version '

Sensors and DIY

A user got blocked when trying to download the flower power app on his smartphone, a non-branded Android 5.11. When opening the download page in Google play store he gets the message: your device isn’t compatible with this version, and as a consequence he can’t download the app. Canyou help? Thank you Tania Walisch

1 comment

Hi Tania. We'll speak to the company who makes the sensor and find out what their response is to this. I know that Victoria from GROW has Android 5.1.1 and has been able to download the app so the problem may be the phone rather than the Android version. If you can find out any more information about the make of the phone, that might be helpful for us.

Reply — Last edited